#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\bhttps?:\/\/\S*(?=(?:(?!http)[\s\S])*https?:\/\/\S*backbone\.com)"
Local $sString = "dfjSKsfkfkSFKfdvsfdvsdv https://text.com " & @CRLF & _
"from https://test2.com sdjgdsdh " & @CRLF & _
"https://backbone.com " & @CRLF & _
"from jfsjfskf https://backbone.com jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")