import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bhttps?:\\/\\/\\S*(?=(?:(?!http)[\\s\\S])*https?:\\/\\/\\S*backbone\\.com)";
final String string = "dfjSKsfkfkSFKfdvsfdvsdv https://text.com \n"
+ "from https://test2.com sdjgdsdh \n"
+ "https://backbone.com \n"
+ "from jfsjfskf https://backbone.com jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}