const regex = /\bhttps?:\/\/\S*(?=(?:(?!http)[\s\S])*https?:\/\/\S*backbone\.com)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bhttps?:\\\/\\\/\\S*(?=(?:(?!http)[\\s\\S])*https?:\\\/\\\/\\S*backbone\\.com)', 'i')
const str = `dfjSKsfkfkSFKfdvsfdvsdv https://text.com
from https://test2.com sdjgdsdh
https://backbone.com
from jfsjfskf https://backbone.com jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}