$re = '/\bhttps?:\/\/\S*(?=(?:(?!http)[\s\S])*https?:\/\/\S*backbone\.com)/i';
$str = 'dfjSKsfkfkSFKfdvsfdvsdv https://text.com
from https://test2.com sdjgdsdh
https://backbone.com
from jfsjfskf https://backbone.com jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);