using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bhttps?:\/\/\S*(?=(?:(?!http)[\s\S])*https?:\/\/\S*backbone\.com)";
string input = @"dfjSKsfkfkSFKfdvsfdvsdv https://text.com
from https://test2.com sdjgdsdh
https://backbone.com
from jfsjfskf https://backbone.com jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}