#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\s|^)\b\d{3}-\d{2}-\d{4}\b(?=\s|$)"
Local $sString = "John Doe SSN# 123-12-1235" & @CRLF & _
"100-123-45-1234-99" & @CRLF & _
"John Smith, SSN, 123-45-1234" & @CRLF & _
"100-123-45-1234-99" & @CRLF & _
"123-45-1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")