use strict;
my $str = 'John Doe SSN# 123-12-1235
100-123-45-1234-99
John Smith, SSN, 123-45-1234
100-123-45-1234-99
123-45-1234';
my $regex = qr/(?<=\s|^)\b\d{3}-\d{2}-\d{4}\b(?=\s|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}