const regex = /(?<=\s|^)\b\d{3}-\d{2}-\d{4}\b(?=\s|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s|^)\\b\\d{3}-\\d{2}-\\d{4}\\b(?=\\s|$)', 'gm')
const str = `John Doe SSN# 123-12-1235
100-123-45-1234-99
John Smith, SSN, 123-45-1234
100-123-45-1234-99
123-45-1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}