$re = '/(?<=\s|^)\b\d{3}-\d{2}-\d{4}\b(?=\s|$)/m';
$str = 'John Doe SSN# 123-12-1235
100-123-45-1234-99
John Smith, SSN, 123-45-1234
100-123-45-1234-99
123-45-1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);