#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*(\S+).*(\sA\s|\sCNAME\s)"
Local $sString = " www.sales 1D IN A 10.0.0.1" & @CRLF & _
" www.learning 1D IN CNAME something" & @CRLF & _
" www.it 1D IN AAAA 1::0::whatever" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")