const regex = /\s*(\S+).*(\sA\s|\sCNAME\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(\\S+).*(\\sA\\s|\\sCNAME\\s)', 'g')
const str = ` www.sales 1D IN A 10.0.0.1
www.learning 1D IN CNAME something
www.it 1D IN AAAA 1::0::whatever
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}