package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(\S+).*(\sA\s|\sCNAME\s)`)
var str = ` www.sales 1D IN A 10.0.0.1
www.learning 1D IN CNAME something
www.it 1D IN AAAA 1::0::whatever
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}