// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*(\S+).*(\sA\s|\sCNAME\s)").unwrap();
let string = " www.sales 1D IN A 10.0.0.1
www.learning 1D IN CNAME something
www.it 1D IN AAAA 1::0::whatever
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}