$re = '/\s*(\S+).*(\sA\s|\sCNAME\s)/';
$str = ' www.sales 1D IN A 10.0.0.1
www.learning 1D IN CNAME something
www.it 1D IN AAAA 1::0::whatever
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);