re = /\s*(\S+).*(\sA\s|\sCNAME\s)/
str = ' www.sales 1D IN A 10.0.0.1
www.learning 1D IN CNAME something
www.it 1D IN AAAA 1::0::whatever
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end