import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "abc";
final String string = "aababcbcd \n"
+ "http://www.python-kurs.eu/re.php\n"
+ "Erklärung für die einfache Suche";
final String subst = "\\1 \\2\\t\\3\\t\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}