import Foundation
let pattern = #"abc"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
aababcbcd
http://www.python-kurs.eu/re.php
Erklärung für die einfache Suche
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \2\t\3\t\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)