// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)abc").unwrap();
let string = "aababcbcd
http://www.python-kurs.eu/re.php
Erklärung für die einfache Suche";
let substitution = "\\1 \\2\\t\\3\\t\\4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}