using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|(?<=\/))
(?:[^\s.\/]+|\.(?!\.\/))++
\/\.\.\/";
string substitution = @"";
string input = @"Find all cases of /folder/../ and replace them with /
/path/./path #ok
/path/path../ #ok
/path./path/ #ok
/../ #ok
/../../ #ok
//../../ #ok
path1/../path2/ #change: 'path2/'
../path/ #change: ''
../../path1/path2 #change: ''
abcedf/earg/../aerg/acde/path/../../../../path../../ #change: ''
path/../ #change: ''
/path/../ #change: '/'
/.git/../ #change: '/'
/path/../../ #change: '/../'
/path/../../../../abc/../ #change: '/../../../'
/../../abc/ #change: '/../'
../../abc/../abc/ #change: '../'
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}