use strict;
my $str = 'Find all cases of /folder/../ and replace them with /
/path/./path #ok
/path/path../ #ok
/path./path/ #ok
/../ #ok
/../../ #ok
//../../ #ok
path1/../path2/ #change: \'path2/\'
../path/ #change: \'\'
../../path1/path2 #change: \'\'
abcedf/earg/../aerg/acde/path/../../../../path../../ #change: \'\'
path/../ #change: \'\'
/path/../ #change: \'/\'
/.git/../ #change: \'/\'
/path/../../ #change: \'/../\'
/path/../../../../abc/../ #change: \'/../../../\'
/../../abc/ #change: \'/../\'
../../abc/../abc/ #change: \'../\'
';
my $regex = qr/(?:^|(?<=\/))
(?:[^\s.\/]+|\.(?!\.\/))++
\/\.\.\//mixp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";