import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|(?<=\\/))\n"
+ "(?:[^\\s.\\/]+|\\.(?!\\.\\/))++\n"
+ "\\/\\.\\.\\/";
final String string = "Find all cases of /folder/../ and replace them with / \n\n"
+ "/path/./path #ok\n"
+ "/path/path../ #ok\n"
+ "/path./path/ #ok\n"
+ "/../ #ok\n"
+ "/../../ #ok\n"
+ "//../../ #ok\n"
+ "path1/../path2/ #change: 'path2/'\n"
+ "../path/ #change: ''\n"
+ "../../path1/path2 #change: ''\n"
+ "abcedf/earg/../aerg/acde/path/../../../../path../../ #change: ''\n"
+ "path/../ #change: ''\n"
+ "/path/../ #change: '/'\n"
+ "/.git/../ #change: '/'\n"
+ "/path/../../ #change: '/../'\n"
+ "/path/../../../../abc/../ #change: '/../../../'\n"
+ "/../../abc/ #change: '/../'\n"
+ "../../abc/../abc/ #change: '../'\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}