import Foundation
let pattern = #"""
(?:^|(?<=\/))
(?:[^\s.\/]+|\.(?!\.\/))++
\/\.\.\/
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = ##"""
Find all cases of /folder/../ and replace them with /
/path/./path #ok
/path/path../ #ok
/path./path/ #ok
/../ #ok
/../../ #ok
//../../ #ok
path1/../path2/ #change: 'path2/'
../path/ #change: ''
../../path1/path2 #change: ''
abcedf/earg/../aerg/acde/path/../../../../path../../ #change: ''
path/../ #change: ''
/path/../ #change: '/'
/.git/../ #change: '/'
/path/../../ #change: '/../'
/path/../../../../abc/../ #change: '/../../../'
/../../abc/ #change: '/../'
../../abc/../abc/ #change: '../'
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)