# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:^|(?<=\/))
(?:[^\s.\/]+|\.(?!\.\/))++
\/\.\.\/
"""
test_str = ("Find all cases of /folder/../ and replace them with / \n\n"
"/path/./path #ok\n"
"/path/path../ #ok\n"
"/path./path/ #ok\n"
"/../ #ok\n"
"/../../ #ok\n"
"//../../ #ok\n"
"path1/../path2/ #change: 'path2/'\n"
"../path/ #change: ''\n"
"../../path1/path2 #change: ''\n"
"abcedf/earg/../aerg/acde/path/../../../../path../../ #change: ''\n"
"path/../ #change: ''\n"
"/path/../ #change: '/'\n"
"/.git/../ #change: '/'\n"
"/path/../../ #change: '/../'\n"
"/path/../../../../abc/../ #change: '/../../../'\n"
"/../../abc/ #change: '/../'\n"
"../../abc/../abc/ #change: '../'\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.