#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:Rs\.?|INR)\s*(\d+(?:[.]\d+)*)\b(?!\,)|(?<!\d\,)\b(\d+(?:[.]\d+)*)\s*(?:Rs\.?|INR)"
Local $sString = "Rs. 2000 , Rs.2000 , Rs 20,000.00 ,20,000 INR 200.25 INR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")