using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:Rs\.?|INR)\s*(\d+(?:[.]\d+)*)\b(?!\,)|(?<!\d\,)\b(\d+(?:[.]\d+)*)\s*(?:Rs\.?|INR)";
string input = @"Rs. 2000 , Rs.2000 , Rs 20,000.00 ,20,000 INR 200.25 INR";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}