import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Rs\\.?|INR)\\s*(\\d+(?:[.]\\d+)*)\\b(?!\\,)|(?<!\\d\\,)\\b(\\d+(?:[.]\\d+)*)\\s*(?:Rs\\.?|INR)";
final String string = "Rs. 2000 , Rs.2000 , Rs 20,000.00 ,20,000 INR 200.25 INR";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}