#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\s#]+\s+/tmp\s+\S+\s+(\S+)"
Local $sString = "/dev/mapper/rootvg-lv_home /home ext4 nosuid,nodev 1 2" & @CRLF & _
"/dev/mapper/rootvg-lv_opt /opt ext4 nosuid,nodev 1 2" & @CRLF & _
"#/dev/mapper/rootvg-lv_tmp /tmp ext4 nosuid,noexec 1 2" & @CRLF & _
"/dev/mapper/rootvg-lv_tmp /tmp ext4 nosuid,nodev 1 2" & @CRLF & _
"/dev/mapper/rootvg-lv_var /var ext4 nosuid,nodev 1 2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")