import re
regex = re.compile(r"^[^\s#]+\s+/tmp\s+\S+\s+(\S+)", flags=re.MULTILINE)
test_str = ("/dev/mapper/rootvg-lv_home /home ext4 nosuid,nodev 1 2\n"
"/dev/mapper/rootvg-lv_opt /opt ext4 nosuid,nodev 1 2\n"
"#/dev/mapper/rootvg-lv_tmp /tmp ext4 nosuid,noexec 1 2\n"
"/dev/mapper/rootvg-lv_tmp /tmp ext4 nosuid,nodev 1 2\n"
"/dev/mapper/rootvg-lv_var /var ext4 nosuid,nodev 1 2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")