import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\s#]+\\s+/tmp\\s+\\S+\\s+(\\S+)";
final String string = "/dev/mapper/rootvg-lv_home /home ext4 nosuid,nodev 1 2\n"
+ "/dev/mapper/rootvg-lv_opt /opt ext4 nosuid,nodev 1 2\n"
+ "#/dev/mapper/rootvg-lv_tmp /tmp ext4 nosuid,noexec 1 2\n"
+ "/dev/mapper/rootvg-lv_tmp /tmp ext4 nosuid,nodev 1 2\n"
+ "/dev/mapper/rootvg-lv_var /var ext4 nosuid,nodev 1 2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}