// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\s#]+\s+/tmp\s+\S+\s+(\S+)").unwrap();
let string = "/dev/mapper/rootvg-lv_home /home ext4 nosuid,nodev 1 2
/dev/mapper/rootvg-lv_opt /opt ext4 nosuid,nodev 1 2
#/dev/mapper/rootvg-lv_tmp /tmp ext4 nosuid,noexec 1 2
/dev/mapper/rootvg-lv_tmp /tmp ext4 nosuid,nodev 1 2
/dev/mapper/rootvg-lv_var /var ext4 nosuid,nodev 1 2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}