$re = '/^[^\s#]+\s+/tmp\s+\S+\s+(\S+)/m';
$str = '/dev/mapper/rootvg-lv_home /home ext4 nosuid,nodev 1 2
/dev/mapper/rootvg-lv_opt /opt ext4 nosuid,nodev 1 2
#/dev/mapper/rootvg-lv_tmp /tmp ext4 nosuid,noexec 1 2
/dev/mapper/rootvg-lv_tmp /tmp ext4 nosuid,nodev 1 2
/dev/mapper/rootvg-lv_var /var ext4 nosuid,nodev 1 2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);