#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:^SI?|\G)\d*)[^\n\d]"
Local $sString = "SI234965305843453" & @CRLF & _
"S234---9Sptreccc6543453" & @CRLF & _
"5492353ffsdkfjsd5345"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)