const regex = /((?:^SI?|\G)\d*)[^\n\d]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:^SI?|\\G)\\d*)[^\\n\\d]', 'gm')
const str = `SI234965305843453
S234---9Sptreccc6543453
5492353ffsdkfjsd5345`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);