use strict;
my $str = 'SI234965305843453
S234---9Sptreccc6543453
5492353ffsdkfjsd5345';
my $regex = qr/((?:^SI?|\G)\d*)[^\n\d]/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";