# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:^SI?|\G)\d*)[^\n\d]"
test_str = ("SI234965305843453\n"
"S234---9Sptreccc6543453\n"
"5492353ffsdkfjsd5345")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.