using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:^SI?|\G)\d*)[^\n\d]";
string substitution = @"\1";
string input = @"SI234965305843453
S234---9Sptreccc6543453
5492353ffsdkfjsd5345";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}