$re = '/((?:^SI?|\G)\d*)[^\n\d]/m';
$str = 'SI234965305843453
S234---9Sptreccc6543453
5492353ffsdkfjsd5345';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;