using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\n([^\n]*\n){1,3}\n";
string input = @"first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4
first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4
first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}