$re = '/^\n([^\n]*\n){1,3}\n/m';
$str = 'first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4
first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4
first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);