// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\n([^\n]*\n){1,3}\n").unwrap();
let string = "first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4
first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4
first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}