const regex = /^\n([^\n]*\n){1,3}\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\n([^\\n]*\\n){1,3}\\n', 'gm')
const str = `first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4
first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4
first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}