re = /^\n([^\n]*\n){1,3}\n/m
str = 'first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4
first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4
first thing: content 1
second thing: content 2
third thing: content 3
fourth thing: content 4
first thing: content 1
second thing: content 2
fourth thing: content 4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end