import re
regex = re.compile(r"^\n([^\n]*\n){1,3}\n", flags=re.MULTILINE)
test_str = ("first thing: content 1\n"
"second thing: content 2\n"
"third thing: content 3\n"
"fourth thing: content 4\n\n"
"first thing: content 1\n"
"second thing: content 2\n"
"fourth thing: content 4\n\n"
"first thing: content 1\n"
"second thing: content 2\n"
"third thing: content 3\n"
"fourth thing: content 4\n\n"
"first thing: content 1\n"
"second thing: content 2\n"
"fourth thing: content 4\n"
"first thing: content 1\n\n"
"second thing: content 2\n"
"third thing: content 3\n"
"fourth thing: content 4\n\n"
"first thing: content 1\n"
"second thing: content 2\n"
"fourth thing: content 4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")