import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\b(?!www\\.)((?:[\\w-]+\\.)+[\\w-]+).*$";
final String string = "http://nike-admin.app.com\n"
+ "google.com\n"
+ "www.google.com\n"
+ "ftp://ftp.google.com\n"
+ "http://www.google.com\n"
+ "http://www.google.com/\n"
+ "https://www.google.com/\n"
+ "https://www.google.com.sg/\n"
+ "http://app.com\n"
+ "http://www.app.com";
final String subst = "https://$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}