$re = '/^.*?\b(?!www\.)((?:[\w-]+\.)+[\w-]+).*$/m';
$str = 'http://nike-admin.app.com
google.com
www.google.com
ftp://ftp.google.com
http://www.google.com
http://www.google.com/
https://www.google.com/
https://www.google.com.sg/
http://app.com
http://www.app.com';
$subst = "https://$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;