re = /^.*?\b(?!www\.)((?:[\w-]+\.)+[\w-]+).*$/m
str = 'http://nike-admin.app.com
google.com
www.google.com
ftp://ftp.google.com
http://www.google.com
http://www.google.com/
https://www.google.com/
https://www.google.com.sg/
http://app.com
http://www.app.com'
subst = 'https://$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result