use strict;
my $str = 'http://nike-admin.app.com
google.com
www.google.com
ftp://ftp.google.com
http://www.google.com
http://www.google.com/
https://www.google.com/
https://www.google.com.sg/
http://app.com
http://www.app.com';
my $regex = qr/^.*?\b(?!www\.)((?:[\w-]+\.)+[\w-]+).*$/mp;
my $subst = 'https://$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";