#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=<\/a>).*?(leoshi)"
Local $sString = "Sample text for testing:<a href="http://www.baidu.com" title="leoshi">leoshi</a>ahdfd leoshi <a href="http://www.baidu.com" title="leoshi">leoshi</a>for details balala..." & @CRLF & _
"Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!" & @CRLF & _
"" & @CRLF & _
"Sample text for testing:<a href="http://www.baidu.com" title="leoshi">leoshi</a>bbfd fdleoshi Sample text for testing:<a href="http://www.baidu.com" title="leoshi">leoshi</a>ahdfd leoshi <a href="http://www.baidu.com" title="leoshi">leoshi</a>for details balala...for details balala..." & @CRLF & _
"Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")