import Foundation
let pattern = #"(?<=<\/a>).*?(leoshi)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Sample text for testing:<a href="http://www.baidu.com" title="leoshi">leoshi</a>ahdfd leoshi <a href="http://www.baidu.com" title="leoshi">leoshi</a>for details balala...
Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!
Sample text for testing:<a href="http://www.baidu.com" title="leoshi">leoshi</a>bbfd fdleoshi Sample text for testing:<a href="http://www.baidu.com" title="leoshi">leoshi</a>ahdfd leoshi <a href="http://www.baidu.com" title="leoshi">leoshi</a>for details balala...for details balala...
Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)