use strict;
my $str = 'Sample text for testing:<a href="http://www.baidu.com" title="leoshi">leoshi</a>ahdfd leoshi <a href="http://www.baidu.com" title="leoshi">leoshi</a>for details balala...
Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!
Sample text for testing:<a href="http://www.baidu.com" title="leoshi">leoshi</a>bbfd fdleoshi Sample text for testing:<a href="http://www.baidu.com" title="leoshi">leoshi</a>ahdfd leoshi <a href="http://www.baidu.com" title="leoshi">leoshi</a>for details balala...for details balala...
Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!
';
my $regex = qr/(?<=<\/a>).*?(leoshi)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}